# Pimcore chdir() permission error

**URL:** https://forum.ficusonline.com/t/pimcore-chdir-permission-error/34
**Category:** WEB Design
**Created:** [2016 年 10 月 12 日午前 8:57 UTC](https://forum.ficusonline.com/t/pimcore-chdir-permission-error/34 "2016-10-12T08:57:53Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![tk-fuse](https://forum.ficusonline.com/user_avatar/forum.ficusonline.com/tk-fuse/32/255_2.png) [@tk-fuse](https://forum.ficusonline.com/u/tk-fuse)
#### Post date: [2016 年 10 月 12 日午前 8:57 UTC](https://forum.ficusonline.com/t/pimcore-chdir-permission-error/34/1 "2016-10-12T08:57:55Z")

</div>

website/var/log/php.logにて下記エラー表示。パーミッションの問題ではあるが、cli/startup.php内の指定パスの実行権の問題。

`PHP Warning: chdir(): Permission denied (errno 13) in /var/www/html/pimcore/cli/startup.php on line 24`

startup.phpファイルの編集

> sudo pico pimcore/cli/startup.php

```
$workingDirectory = getcwd();
chdir( __DIR__ );
include_once("../../config/startup.php");
chdir($workingDirectory);

```

**include\_once(“../config/startup.php”)**  
を  
**include\_once(“../../config/startup.php”)**  
とする。

実行権のあるフォルダまで階層を上げて指定することにより解決。

参考URL

> <https://stackoverflow.com/questions/37282362/how-to-run-a-cli-script-in-pimcore>

---

<div class="post-metadata">

### Author: ![tk-fuse](https://forum.ficusonline.com/user_avatar/forum.ficusonline.com/tk-fuse/32/255_2.png) [@tk-fuse](https://forum.ficusonline.com/u/tk-fuse)
#### Post date: [2016 年 10 月 14 日午前 12:51 UTC](https://forum.ficusonline.com/t/pimcore-chdir-permission-error/34/2 "2016-10-14T00:51:25Z")

</div>

上記対応ではメインテナンススクリプトにエラーが発生。元に戻す。

> sudo -u www-data php7.0 /var/www/html/pimcore/cli/console.php maintenance

> PHP Warning: include\_once(…/…/config/startup.php): failed to open stream: No such file or directory in /var/www/html/pimcore/cli/startup.php on line 23

---

<div class="post-metadata">

### Author: ![tk-fuse](https://forum.ficusonline.com/user_avatar/forum.ficusonline.com/tk-fuse/32/255_2.png) [@tk-fuse](https://forum.ficusonline.com/u/tk-fuse)
#### Post date: [2016 年 10 月 14 日午前 7:42 UTC](https://forum.ficusonline.com/t/pimcore-chdir-permission-error/34/3 "2016-10-14T07:42:24Z")

</div>

Apacheのアクセス権は問題なく、原因はクローンジョブの記述。以下console.phpまでのダイレクトパスを記述。直前のsudo -u www-data の余計な装飾は必要ない。

> \*/5 \* \* \* \* php /var/www/html/pimcore/cli/console.php maintenance
